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Getting OS Digital Terrain Models into CAESAR 

 
This tutorial will guide you through the process of preparing an Ordnance Survey 

(OS) digital terrain model (DTM) for use in CAESAR, the following software will be 

utilized:  

• ESRI ArcGIS 9.1 

• Arc Hydro Toolset (http://www.crwr.utexas.edu/archydrotools/tools.html) 

• NTF2MIF (http://www.bodley.ox.ac.uk/guides/maps/translat.htm) 

• RasterEdit (http://www.coulthard.org.uk/downloads/downloads.htm) 

 

Part 1: Getting OS Digital Terrain Models into ArcGIS 
 

   DTM Acquisition 

If you have a subscription to Digimap (http://edina.ac.uk/digimap/), you can freely 

download DTMs covering the UK.  The OS offers two types of DTMs, the OS Land-

Form PROFILE DTM, 1:10000 (10m resolution) and the OS Land-Form 

PANORAMA DTM, 1:50000 (50m resolution).  In this example a 10m DTM will be 

processed, note that this data is available in NTF format.  Proceed to download the 

DTM tiles of your interest. 

Importing OS DTM into ArcGIS 

Currently ArcGIS can not directly import NTF files without a built-in conversion tool 

(MapManager 9.1) which is not freely available.  Therefore, files in NTF format must 

be converted into a file format that can be imported into ArcGIS.  The following steps 

guide you through the process of converting NTF files into MIF files, MIF files into 

ArcGIS shapefiles and lastly converting the shapefile point features into an ArcGIS 

raster. 

1. Download, install, and run NTFMIF.  This freeware converts NTF files into 

MIF files. 

2. Load all your NTF files into the translator at once, and select separate tiles as 

your output option (fig. 1).  For some reason merging your data into a single 

tile produces errors in the final outcome.   

 

Fig. 1 NTF2MIF interface 
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3. Click on translate, your NTF files will be converted into MIF files which are 

stored in the same directory as the NTF files. 

4. Open ArcGIS ArcCatalog, on the toolbar located at the top of the window, 

click on View->Toolbars->Customize.  You will now place a check mark 

next to ArcView 8x Tools (fig. 2).  Return to ArcCatalog’s main window and 

notice that a Conversion Tools button has been added. 

 

 
 

 

5. Click on the new Conversion Tools button and select MIF to Shapefile.  Fill 

in the textboxes appropriately, selecting the MIF file as the input, creating a 

point feature class, and naming the resulting shapefile in a directory without 

spaces in the name (fig. 3).  Repeat this process for all of your MIF files. 

 

 
 

 

6. Open ArcGIS ArcMap, and add all the point shapefiles that you have created.  

Open the attribute table of one of the point shapefiles and notice that each 

point has a height value. 

7. Make sure that ArcToolbox is open by pressing the ArcToolbox button .  

Navigate to the Merge tool by opening the Data Management Tools toolbox-

>General toolset.  You should now merge all of your shapefiles into a single 

shapefile.  

8. The resulting merged shapefile can now be converted into an ArcGIS raster.  

In the ArcToolbox tree open the Conversion Tools toolbox->To Raster 

toolset->Feature to Raster tool.  The merged shapefile will serve as input and 

the height field will supply the raster cell values.  Output cell size should be 

set to 10m, although ArcGIS may recommend something different. 

 Fig. 2 Panel to add ArcView 8x conversion tools 

 

Fig. 3 Panel for MIF to shapefile conversion 
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9. The resulting DTM’s height values need to be rescaled into meters.  Make sure 

that your Spatial Analyst toolbar is visible and the extension is activated.  

Open the Spatial Analyst Raster Calculator and construct the following 

expression, substituting “Your_Raster_File” with the name of your raster: 

[DTM] = Float([Your_Raster_File]) / 10 

10. To make the DTM permanent, right click on DTM in the table of contents 

window, and select Make Permanent… 

11. Return to ArcCatalog and navigate to the newly created DTM’s directory, if 

the DTM does not appear, within ArcCatalog right click on the folder 

containing the DTM and select Refresh. Right click on the DTM and select 

Properties…  Scroll down to Spatial Reference, notice that it is undefined; 

you will now define the coordinate system for the DTM.  

12. Click the Edit… button next to Spatial Reference, select to define the 

coordinate system interactively. 

13. Select the Great Britain Grid as your projection and click next, on the next 

form accept the default values and click next. 

14. Select ORDNANCE SURVEY OF GREAT BRITAIN 1936 from the list of 

datums and finally click on finish. 

 

Part 2: OS DTM Preparation for CAESAR 

 
Hopefully you have successfully imported your OS DTM into ArcGIS, but the DTM 

may require spatial adjustments, editing and hydrological conditioning before it can 

be loaded into CAESER.  The next section will guide you through theses processes. 

Rotation 

CAESAR is set up so the main direction of flow is from left to right, so the 

catchment exit point has to be on the right hand end of the DTM.  If the main flow 

of your DTM is in any other direction (fig. 4a) you will have to re-orient your 

DTM (fig. 4b).  Follow these steps to rotate your DTM: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. Open ArcMap and add your DTM. 
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Fig. 4 (a) DTM with flow bottom to top.  (b) Same DTM rotated 90˚, flow is now left to right 
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2. In ArcToolbox navigate to the Data Management Tools toolbox-

>Projections and Transformations toolset->Raster toolset->Rotate 

tool. 

3. Rotate your DTM accordingly so the river’s main flow is from left to 

right, note that the default pivot point is the lower left corner of your 

DTM.  Furthermore, rotate your DTM only in multiples of 90˚, not 

doing so will result in resampling, and will change your DTM values. 

Resampling 

CAESAR can run with up to 2 million grid cells, but is probably best suited to 

applications with 250 000 to 500 000 cells. Quite simply, the smaller the number 

of grid cells, the faster the model will operate.  One way to reduce the number of 

grid cells is to resample your DTM to a coarser spatial resolution. 

1. Within ArcMap, add your DTM , and within ArcToolbox navigate to 

the Data Management toolbox->Raster toolset->Resample tool. 

2. Set the input and output rasters, new cellsize and select bilinear as the 

resampling technique which is useful for continuous data.  Be aware 

that this resampling technique will cause some smoothing of the data.  

Also, set your cellsize to an integer value type, CEASAR will not 

accept cellsizes with decimal places. 

DTM Editing 

Sometimes you will find that your DTM has major obstacles across the channel 

which will block the downstream flow of your river within CEASAR (fig. 5). If 

you need to remove obstacles from your DTM use the freeware tool RasterEdit. 

 

 

 

 

   

 

 

 

 

 

 

 

 

 

1. Within ArcMap, add your DTM, and within the ArcToolbox navigate 

to the Conversion Tools toolbox ->From Raster toolset->Raster to 

ASCII tool.  This tool will convert your DTM into an ASCII file 

which you can load into RasterEdit. 

2. Open RasterEdit, and load your DTM in ASCII format (e.g. DTM.asc 

or DTM.txt).   

3. To find  the obstacle you wish to remove change the zoom level in the 

Display Options  tab and use the scrollbars to navigate. 

4. Once you’ve located the obstacle, click on Reach Edit Mode and 

make sure that Mark interpolation points is selected. 

Fig 5 DTM with bridge blocking the river channel 
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5. You will now click on the cells that are within the river channel and 

adjacent to your obstacle (fig. 6). 

 

 
 

 

 

6. Return to the Display Options tab and click on Interpolate new point 

values.  Proceed to click on the cells that represent the obstacle, notice 

how the cells change color, indicating the newly interpolated height 

value (fig.7). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

7. Once you’ve finished removing the obstacle, close RasterEdit, and 

click the Save Changes button on the File tab.  Save your results with 

a .txt or .asc extension and close RasterEdit. 

8. Open ArcMap, and within the ArcToolbox navigate to the Conversion 

Tools toolbox ->To Raster toolset->ASCII to Raster tool.  This tool 

will convert your RasterEdit ASCII file into an ArcGIS raster. 

9. As input enter the .asc or.txt you created with RasterEdit, set the output 

raster file name, and select float as the Output data type.  Setting the 

data type to float will ensure that decimal height values in your DTM 

are retained. 

 

 

Fig. 6 DTM in RasterEdit with interpolation points 

marked above and below an obstacle. 

Fig. 7 DTM in RasterEdit with interpolation points marked above 

and below an obstacle (blue) and interpolated point values (red) 
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Hydrological Conditioning 

In this section you will fill sinks, extract the main drainage network, delineate the 

river catchment, edit the river catchment, clip the DTM to the river catchment and 

burn the main drainage network into the DTM. 

Installing ArcHydo Tools 

1. Download and install Arc Hydro Tools. 

2. Open ArcMap and click on View->Toolbars.  Check off Arc Hydro 

Tools.  Dock the toolbar. 

 

 
 

 

Filling Sinks 

1. Add your DTM to ArcMap and save the current project . 

2. Click on the Terrain Preprocessing button, and click on Fill Sinks.  This 

process will fill sinks in your DTM and fix small imperfection in the data.  

Input your DTM and click OK. 

Extracting the Main Drainage Network 

1. Next, using Arc Hydro tools, calculate the Flow Direction (Fdr) and Flow 

Accumulation (Fac) of your filled DTM.  Inspect the resulting flow 

accumulation layer (Fac), and make sure that the flow of the river is not 

interrupted.  Below, the flow accumulation of the DTM on the left (a), 

illustrates uninterrupted flow, while the same section of river on the right 

(B) illustrates interrupted flow.  If you have interrupted flow, repeating the 

Fill Sinks step may correct this problem. 
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Fig. 8 Adding the ArcHydro Toolbar 

Fig. 9 River channel with uninterrupted flow (a) and interrupted flow (b). 



 7 

2. The flow accumulation raster (Fac) contains values of accumulated flow to 

each cell. Cells with greater values tend to represent the river’s main 

drainage pattern.  If you are interested in extracting the main drainage 

pattern re-symbolize your DTM by right clicking on Fac in the table of 

contents, selecting Properties…, clicking on the Symbology tab and 

clicking on the classified option.  Click on the Classify… button and 

change the classification method to standard deviation.  Click OK. 

3. Drag the flow accumulation raster’s Layer Properties window to the 

upper left hand corner of your screen to make your map visible.  You will 

now visually determine a threshold value for Fac that represents the main 

drainage network by individually changing the color of your classes.   

4. Double click on the white symbol box (fig. 10a) and choose a different 

color (e.g. red), click Apply.  Notice that cells representing the main river 

channel are now a different color (fig. 10b).  Continue to re-symbolize 

your DTM until the main drainage pattern is clearly visible. 

5. Write down the first value of the lowest classification range which you re-

symbolized (e.g. 2996).  This value will be used to extract the main 

drainage network. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

6. Close the Layer Properties window, and click on the Terrain 

Preprocessing button.  Select Stream Definition and click OK, in the 

following dialog enter the value you previously recorded in the Number 

of cells textbox and click OK. 

7. Proceed with the remaing terrain preprocessing steps until you complete 

Drainage Line Processing.  

 

a 

b 

c 

Fig. 10 Visually extracting the main drainage pattern. 
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This section has produced the following layers that will be used to finalize the 

conditioning of your DTM: 

• Catchment (polygon):  catchment for each stream segement 

• DraingaeLine (polyline): river’s main drainage network 

• fil (grid):  DTM with sinks filled 

DEM Clipping 

1. Display the follwing three layers within ArcMap: fil, Catchment and 

DrainageLine, remove all other layers (fig.11a).  You will now clip your 

DTM to your area of interest by editing the Catchment layer. 

2. Display the Catchment layer with a hollow fill and a red outline. 

3. Make sure that your Editor toolbar is visible, and click on Editor->Start 

Editing.  Make sure that the Catchment layer is the target layer . 

4. Holding the shift key down proceed to click on the sub catchmnets that are 

not in your area of interest.  When you have completed your selection 

press the delete key on your keyboard (fig. 11b).  The remainng sub 

catchmnets will be used to clip your DEM. 

 

 

 

 

 

 

 

 

 

 

 

 

 

5. Your resulting Catchment layer may have an uneven right hand edge, as 

marked in fig. 11b.  If this is the case, continue editing the Catchment 

layer to produce a flush right hand edge by clipping.  If  the right hand 

edge of your catchment is flush, save your edits, stop editting, and proceed 

to step 12 in this section. 

6. Zoom into the right hand edge of your Catchmnet layer.  On the Editor 

toolbar, click on the edit task button , select Cut Polygon Features, 

and close the drop down menu. 

7. On the Editor toolbar, select Snapping…, and check off edge for the 

Catchment layer.  Close the snapping window. 

8. Using the Edit Tool , click once on the sub catchment that contains the 

uneven right hand edge.  Click on the Sketch Tool .   

9. You will now clip the sub catchment  so the the right hand edge is flush.  

First, click on the boundary of the polygon where you would like to begin 

your cut (fig. 12).  Notice that, as previously set, the crosshairs snap to the 

catchment boundary.  Next, double click on the boundary of the polygon 

Fig. 11 Catchment, DrainageLine, and Fil, before (a) and after editing (b). 

a 
b 
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where you would like to complete your cut, make sure that the cut is 

perfectly flush (fig. 13a). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

10. Your sub catchment should now be sub-divided, you will now delete the 

eastern portion to produce a flush edge for your river’s exit point (fig. 

13b). 

11. Clear all the selected features by clicking on the Main Menu toolbar-

>Selection->Clear Selected Features.  Proceed to select the easternmost 

polygon in your sub catchment and press the delete key.  Click on the 

Editor button, save your edits and stop editting. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

12. It is necessary to recalculate the extent of your edited Catchment layer, the 

extent is important in clipping the DTM correctly.  To recalculate the 

extent right click on the Catchment heading in the table of contents and 

select Data->Export Data…  Name the output shapefile Catchment_Clip 

and add it to ArcMap.  

13. You will now clip your filled DTM (fil) to the catchment of your river.  

Click on Spatial Analyst and select Options…, on the General tab set the 

Analysis Mask to the Catchment_Clip layer and on the Extent tab set the 

Analysis Extent to the Catchment_Clip layer, click OK.  Now any 

Fig. 12 Cutting the easternmost sub catchment. 

Fig. 13 Easternmost sub catchment subdivided into two polygons (a), rightmost 

portion deleted to produce flush edge.  

a b 
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operation performed on a raster, using Spatial Analyst, will be clipped to 

your Catchment_Clip layer. 

14. Clip your DTM by typing the following expression into Spatial Analyst’s 

Raster Calculator: 

[DTM_clip] = [fil] 

15. Turn off the fil layer, open the Properties… of your DTM_clip layer.  On 

the Symbology tab display the NoData values with a color.  Your DTM 

should not have any NoData values blocking the exit point of your river 

(fig. 14). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

16. In the table of contents right click on your clipped DTM and make it 

permanent.  

DEM Reconditioning 

1. Using ArcHydro tool’s DEM Reconditioning feature, you will “burn” the 

existing drainage network into your clipped DEM.   Click on the Terrain 

Preprocessing  menu and select DEM Reconditioning. 

2. The Raw DEM is your clipped DTM, Agree Stream is the DrainageLine 

layer you produced earlier and AgreeDEM is the output of this process. 

3. In the next dialog enter the value 1 as the vector buffer, and 0 as the 

smooth drop/raise, and 1 as the sharp drop/raise.  These parameters will 

decrease the values of the clipped DTM intersecting the stream network by 

approximately 1 vertical unit (meter) and the width of 1 cell. 

4. AgreeDEM can now be exported to ASCII using the Conversion Tools 

toolbox->To Raster toolset->ASCII to Raster tool.  Make sure that your 

output data type is float so you don’t lose the decimal places in your 

elevation values. 

5. Lastly, use a text editor (e.g. wordpad) to open and inspect your DTM in 

ascii format. 

Your DTM in ascii format is now ready for CAESAR. 

NoData 

Fig. 14 Clipped DTM without NoData values blocking the river’s exit point. 


